/MINIZED /_\V N E T

Reach Further™

MiniZed: Creating a Zyng
Hardware Platform in Vivado

Overview

With a traditional processor, the hardware platform is pre-defined. The manufacturer selected
the processor parameters and built-in peripherals when the chip was designed. To make use of
this pre-defined processor, you need only target that specific hardware platform in the software
development tools.

The Zyng-7000 All Programmable SoC is different. Zynq provides multiple building blocks and
leaves the definition to you as the design engineer. This adds flexibility, but it also means that a
bit of work needs to be done up front before any software development can take place.

The first step in completing a Zynq design is to define and build the hardware platform. The
purpose of this tutorial is to show you how to quickly and easily create a base hardware platform
for MiniZed.

Objectives
When this tutorial is complete, you will be able to:
e Create a new project in Vivado, targeting MiniZed
e Create a block based design to insert an ARM processor core
e Import the MiniZed Zynq PS Preset settings
e Build and export the hardware platform

Experiment Setup
Software
The software used to test this reference design is:

e Windows-7 64-bit

e Xilinx Vivado 2017.1

e Board Definition Install for Vivado 2017.1

O MiniZed: http://minized.org/support/documentation/18891

Hardware
The hardware setup used to test this reference design includes:
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e Win-7 PC with the following recommended memory?:
0 1.6 GB RAM available for the Xilinx tools to complete a XC7Z010 design
0 2.3 GB RAM available for the Xilinx tools to complete a XC7Z015 design
0 1.9 GB RAM available for the Xilinx tools to complete a XC7Z020 design
O 2.7 GB RAM available for the Xilinx tools to complete a XC7Z030 design
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Experiment 1. Create a New Zyng Project in Vivado

The MiniZed development board is supported by Vivado WebPack (which is free). The Zynq
Processing System (PS) may be used without anything programmed in the Programmable Logic
(PL). This PS-only style is the simplest way to use Zyng, so that is what we will do during this lab.
However, the power of Zynq is found in using soft IP in the PL, interconnecting PS to PL, and
routing extra PS built-in peripherals through EMIO to PL I/Os, and then programming of the PL is
required.

This tutorial will take advantage of built-in 3™-party board definition files.
e www.minized.org = Support 2 Documentation = MiniZed = MiniZed Board Definition
Install for Vivado 2017.1

1. If not previously completed, download the MiniZed Board Definition Install for Vivado
2017.1 archive and follow the instructions to install the board definitions.

2. Launch Vivado by selecting Start = All Programs = Xilinx Design Tools = Vivado 2017.1
- Vivado 2017.1.

3. Select File > New Project or click on Create New Project under Quick Start.

¢ Vivado 2017.1 L o e e |
File  Flow Tools Window  Help Quick Access
HLx Editions

Quick Start

Create Project >
Open Project >
Open Example Project >

Figure 1 — Vivado Launched

4. Click Next >.
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S

Create a New Vivado Project

VIVADO' This wizard will guide you through the creation of a new project.

HLx Editsans

To create a Vivado project you will need to provide a name and a
location for your project files. Mext, you will specify the type of flow you'll
be working with. Finally, you will specify your project sources and
choose a default part.

& XILINX

& PROG RARMMBARLT -

I'f';\l
L2 Mext = Cancel

Figure 2 — New Vivado Project Wizard Launched

5. Click the browse icon E] Browse to set the Project location to your desired project
location and click Select.

6. Set the Project name to MiniZed_Basic_System. Also verify the Create project
subdirectory checkbox is selected. Click Next >.
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Project Name

Enter a name for your project and specify a directory where the project data files will ‘
be stored.
Project name: MiniZed_Basic_System |
Project location: | CJAvnetMiniZed/Projects IZ'

v Create project subdirectory

Project will be created at: C:/AvnetMiniZediProjects/MiniZed_Basic_System

Pt

Figure 3 — Set Project Name and Location

7. The project will be RTL based, so leave the radio button for RTL Project selected. Since
this is a brand new project, check the box for Do not specify sources at this time. Click
Next >.
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Project Type

Specify the type of project to create. ‘

1 s RTLProject
- vou will be able to add sources, create block designs in IP Integrator, generate [P, run

RTL analysis, synthesis, implementation, design planning and analysis.

2 <+ Do not specify sources at this time

Post-synthesis Project: You will be able to add sources, view device resources, run
design analysis, planning and implementation.

110 Planning Project
Do not specify design sources. You will be able to view part'package resources.

Impaorted Project
Create a Vivado project from a Synplify, XST or ISE Project File.

Example Project
Create a new Vivado project from a predefined template.

7
2 = Back '3;

Figure 4 — Set Project Type

Cancel

Next, the Default Part is selected. This can be done by specifying a specific part or by selecting
a board. If you have installed the Board Definition archive correctly, you will have access to
the MiniZed BDF.
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8. Inthe Select area, select Boards.
9. Set the Vendor to em.avnet.com. This should leave only seven boards in the table.

10. Single-click the MiniZed Click Next >.

Default Part

Choose a default Xilinx part or board for your project. This can be changed later. ‘

4

- T 1
Select {8} Parts || B Boards

~ Filter/ Preview

Vendor: ’2 II em.avnet.com vI
Display Name: | All Remaining i
Board Rey: Latest L
Reset All Filters
Search: L e
Display Mame Vendor Part Board Rev /0 Pin Count  File Version
@ MicroZed 7010 Board em.avnet.com 48 xc7z010clg400-1 f 400 11 -
@ MicroZed 7020 Board em.avnet.com 48 xc7z020clg400-1 f 400 11
3] & MiniZed em.avnet.com {8 xc7z007sclg225-1 a 225 11 I
S’
@ PicoZed 7010 SOM + FMC Carrier V1 em.avnet.com 48 xc7z010clgd400-1 C 400 11
@ PicoZed 7010 SOM + FMC Carrier V2 em.avnet.com 48 xc7z010clg400-1 [ 400 11 -
£ 3

Mo Board Connectors

Ir;—\l - Cirnick
\2) = Back MNext = FEinis Cancel

Figure 5 — Select the Target Board
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11. A project summary is displayed. Click Finish. The Vivado cockpit is now displayed.

New Project Summary

VIVADO!

HLx Editsons © AnewRTL project named 'MiniZed_Basic_System’ will be created.

© The default part and product family for the new project:
Default Board: MiniZed
Default Part: xc7z007sclg225-1
Product: Zyng-7000
Family: Zyng-7000
Package: clg225
Speed Grade: -1

& XILINX

ALL PROG RAMMADLE- To create the project, click Finish

©

Figure 6 — New Project Summary

=, - | P - I = Ot Lyt
Tlow Hasgato ERRe] PROJECT MAMAGER - WriZsd_Basic_Srssem ? %
- PHOJICT MANAGE
] " Soarces % | Project Semmary
£ Setngs
a F & + o
- seitags £t
Drsign Sourcas
BT > 5 Consiminks Ficiectaame VeriZed_Basic,_System
T Catwog % Simulaton Sources g Baskc_gratem
st Prostama T T
v PETESRATOR Pt pat e
Creats thocx Design Top meddy narme
Targetlanguage

Samutat lanpuage

v SLATGN T Py
— Merarchy  Lsones  Cemps rosr o o
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v RTLANALYES Sk
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Figure 7 — Vivado Cockpit
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Experiment 2: Create and Edit a Block Design

The current project is blank. To access the ARM processing system, we will add an embedded
source to the Vivado project using IP Integrator.

1. The recommended way to add an embedded processor is through the Block Design
method via IP Integrator. Select Create Block Design.

¢ MiniZed_Basic_System - [Ci/&vnet/MiniZed/Projects/Minided_Basic_System/MiniZed_Basic 2

File  Edit Flow Tools  Window  Layout \View  Help L~ Cluick Ace

=, - B o X
Flow Navigator o e S PROJECT MAMNAGER - MiniZed_Basic_System
~ PROJECT MANAGER
Sources
£} seftings
a T ¢ +

Add Sources

Design Sources

Language Templates

> Constraints

IF IP Catalog ~ [ Simulation Sources
sim_1

v P INTEGRATOR

Create Block Design

Cpen Block Design

Generate Block Design

Figure 8 — Create Block Design
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2. Give the Block Design a name. System is commonly used. Click OK.

- B
¢ Create Block Design ﬁ

Please specify name of block design.

Design name: System
Directory: = =Local to Project= hd
Specify source set: Design Sources ~

Ir"_?-\l
2 OK Cancel

Figure 9 — Block Design Name

+

3. In the Diagram window, click the Add IP text icon in either location.

Diagram

o O + = C

This design is empty. Press the + button to add IP.

Figure 10 — Add IP to the Block Design
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4. The Add Sources window opens. Start typing “Zyng” in the search window. Find the
ZYNQ?7 Processing System IP. Either double-click this or drag and drop to the Diagram
window.

Search: ng (1 match)

4F ZYNQT Processing System

EMNTER to select, ESC to cancel, Cirl+C for IP details

Figure 11 — Add IP Window
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The Zyng Processing system will appear in the Diagram window. Also a new tab will appear
labeled Address Editor.

BLOCK DESIGHN - System *

Sources Design »  Signals Board ? 00 Diagram » JAddress Editor Xh
Q = H o @ a @ & © Q +

4, System

}* Designer Assistance available. Run Block Automation
» 4F processing_system7_0 (ZYNQ7 Processing System:5.5)

processing_system7_0

DDR + |||

- FIXED_I0 + |||

M_AxGPoACLK 7N N|() M FA;[KG?EK:—
FCLK_RESETO_N

ZYNQT Processing System

Figure 12 — Updated Block Diagram

5. Similar to the Add IP prompt in the previous step, notice now that the Designer
Assistance has provided the hint to Run Block Automation. Click the Run Block
Automation link at the top of the window.

Diagram ¥ Address Editor X
@ a X I © Q + E C o

}“ Designer Assistance available | Run Block Automation

processing_system7_0

.

DDR + |||
- FIXED_IO + |||
= M_AXI_GPO_ACLK ZYNQ M :;:KGZ{EK;—_
FCLK_RESETO_N P

-

ZYMQT Processing System

Figure 13 - Run Block Automation
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6. Notice the block automation wizard has identified two sources of I/O that need to
be made external. One is obvious, the DDR interface. The other is labeled
FIXED_IO. FIXED_IO is basically the MIO pin connections. They are labeled
FIXED_10 because you cannot change their assignments in this window.

The Apply Board Preset checkbox applies the Preset TCL that was included as part
of the board definition archive. Leave this checked. For details about how to build
a system manually, please see the Avnet Zynqg Hardware Development Speedway.

The Cross Trigger options may be left Disabled.

Click OK to connect these external signals.

¢ Run Block Automation =

Automatically make connections in your design by checking the boxes of the blocks fo connect. Select a block on the left fo display its
configuration options on the right ‘

Q = -
= ¥

~ | All Automation (1 out of 1 selected)

Description
This option sets the board preset on the Processing System. All current properties will be
| 4F processing_system7_0 overwritten by the board preset This action cannot be undone. Zyng7 block automation
applies current board preset and generates external connections for FIXED_IO, Trigger
and DDR interfaces.

NOTE: Apply Board Preset will discard existing IP configuration - please uncheck this box,
if you wish to retain previous configuration.

Instance: /jprocessing_system7_0
Options

Make Interface External: FIXED_|O, DDR

Apply Board Preset: ¥
Cross Trigger In: Dizable ~

Cross Irigger Out: Disable

Figure 14 — Run Block Automation

7. You will now see the Zynq block with external I/0.
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processing_system7_0

GPIO 0 +
DDR +
FIXED 10 +

Il
I DDR
I

UART_0 + |||
Il
I
I

FIXED_IO

- IC 0 +
ZYNQ. SDIO. 0 +
USBIND 0 +

FCLK_CLKO =~

FCLK_CLK1 —

FCLK_RESETO N ©-

ZYNQT Processing System

Figure 15 - Zynq Block Diagram for MiniZed with External 1/O

8. At this point, we can validate our design. Click the Validate Design icon A
successful validation window will appear. Click OK.

Diagram X Address Editor X

@ ooom O Q + ¥ C 9 &

processing_systemy_0

-
.

GPIO_0
DDR

FIXED_IO

UART O

- Ic_o
ZYNQ SDIO_0
USBIND_O

FOLK_CLKD =

FCLK_CLK1 |

FCLK_RESETO_N Jo.

[ DDR

[O FIXED_IO

++ 4+ 4+ ++ 4+

L%

Y NOT Processing System

Figure 16 - Validate Zynq Block Design
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. E=X=)

-
4 Validate Design

o Validation successful. There are no errors or critical warnings in this design.

Figure 17 — Validation Successful

9. Click Save Block Design icon, Il , to save the project.

¢ MiniZed_Basic_System - [C:Iﬁlvnetﬂ'iliniEed.ﬂ’ijecB,fMinEed_Basic_Systerm’MiniZed_Basic_System.xpr] - Vivado 201

Eile Edit Flow Tools Window Layout  View Help Q- Quick Access

=, b - = b, B & X

Flow Navigai.. ’ BLOCK DESIGHN - System *
~ PROJECT MANAG ) )
Sources Design ®% Signals Board ?_00
£} Settings
b i
Q = H o
Add Sources
A System
Language Templates
guag F » External Interfaces
iF IP Catalog » Interface Connections
» ¥F processing_system7_0 (ZYNQ7 Processing System:5.5)
~ |PINTEGRATOR

[ S Y N R P —

Figure 18 - Save Block Design

10. Switch to the Sources tab by clicking on it.
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BLOCK DESIGHN - System *

Sources Design Signals Board 2 00

Q =
b Design Sources (1)

» &E System (System.bd) (1)

> Constraints

- Simulation Sources (1)

» sim_11(1)

Figure 19 — Sources Tab

11. Right-click on System (System.bd) and select Create HDL wrapper.

BLOCK DESIGH - System *

Sources ¥ Design Sﬁléht b“&k* 00
Qa T & +

w Cesign Sou

¥ Constraints Source Mode Propertie

w o Simulation S = Open File

> osim_1 (1 Create HDL Wrapper...

Yiew Instantiation Template

Figure 20 - Create Top Level HDL Wrapper

12. For now, leave the option selected to Let Vivado manage wrapper and auto-update. Click
OK.

Page 16

Copyright © 2017 Avnet, Inc. AVNET, “Reach Further,” and the AV logo are registered
trademarks of Avnet, Inc. All other brands are the property of their respective owners.

LIT#



AAVNET

/MINIZED
Reach Further™
B

-
# Create HDL Wrapper
You can either add or copy the HDL wrapper file to the project. Use copy option if

you would like to modify this file.

Options

O Copy generated wrapper to allow user edits

#* | et Vivado manage wrapper and auto-update

Figure 21 - Let Vivado Manage Wrapper

13.0Once the top-level wrapper is created, you can see the design hierarchy in the
Sources tab. Notice that System_wrapper.v is the top-level HDL wrapper that was

created. System.bd is the Block Design.

BLOCK DESIGH - System
Sources x Design Signals | Board ? 00
aQlz|[¢|+ o
~ Design Sources (1)
~ WE A System_wrapper (System_wrappery) (1)
~ @0 System_i: System (System.bd) (1)
ocessing_systemv_0_0.xci)

~ @ System (System.y) (1)
T processing_system7_0 : System_processing_system7_0_0 (System_pr

» Constraints
Simulation Sources (1)

> sim_11(1)

Hierarchy |IP Sources Libraries Compile Order

Figure 22 — System_wrapper.v Generated
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14. Click Generate Bitstream in the Flow Navigator window.

¥ PROGRAM AMD DEBUG

¥ Generate Bitstream

» (Open Hardware Manager

Figure 23 — Generate Bitstream

15. Click yes to start Synthesis and Implementation flows. Launch runs window will open,
Select Ok for the default configurations. Check the upper right-hand corner of the tool
for a status bar.

Mo Implementation Results Available

There are no implementation results available. OK to launch synthesis and implementation?
‘Generate Bitstream” will automatically start when synthesis and implementation completes.

Don't show this dialog again

1=
w
0n
=
(=]

Figure 24 -- Launch Synthesis and Implementation

¢ Launch Runs @
Launch the selected synthesis orimplementation runs. ‘
Launch directory: | =0 <Default Launch Directory= ~

QOptions
® Launch runs on local host  Mumber of jobs: | 4w

Generate scripts only

Don't show this dialog again

Figure 25 — Launch Runs Configurations
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Running synth_design Cancel 2
Figure 26 — Progress Status

16. When bitstream generation is completed, click OK to Open Implemented Design.

i, -

Bitstream Generation Completed 22

o Bitstream Generation successfully completed.

Next
* Open Implemented Design
View Reports
Cpen Hardware Manager

izenerate Memory Configuration File

Don't =show this dialog again

Figure 27 — Open Implemented Design
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Experiment 3: Export Hardware Platform to SDK
Now that we’ve created an embedded system, we must make this platform available to the
Software Development Kit (SDK). This is done by exporting the hardware platform.

1. Inthe Vivado tool, select File > Export = Export Hardware. Check the box to Include
bitstream. Click OK. You could specify a different directory, but for now, leave it as Local
to Project.

Export hardware platform for software
development tools.

anlude bitstream

Exportto: | &0 =Local to Project=

Cancel

Figure 28 — Export Zynq Hardware Platform

2. We will now explore what you have created. In Windows Explorer, browse to your project

directory.
Mame : Date modified Type Size
. Minifed_Basic_System.cache 6/5/2017 1:42 PM File folder
. Minifed_Basic_Systern.hw 6,/5/2017 12:07 PM File folder
. Minifed_Basic_System.ip_user_files 6,/5/2017 12:07 PM File folder
. Minifed_Basic_Systern.runs 6,/5/2017 1:42 PM File folder
, MiniZed_Basic_System.sdk 6,/5/2017 1:48 PM File folder
. Minifed_Basic_System.sim 6/5/2017 12:07 PM File folder
. Minifed_Basic_Systern.sres 6/5/2017 12:09 PM File folder
¢ MiniZed_Basic_Systern 6,/5/2017 1:42 PM Vivado Project File 9 KB

Figure 29 — Project Directory Contents after Export to SDK
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You will notice seven directories and one file here. The .xpr file is your Vivado Project File and
can be used to re-launch your project when you come back to work on it some more.

The .cache, .hw, .runs, .sim, and .srcs directories contain everything related to the hardware
design, including the block design source, wrapper HDL, and synthesis/implementation results.

The .sdk folder is the result of the Export Hardware operation. Everything required for SDK to
import the hardware platform is contained inside one file inside this directory. A hardware
engineer looking to share the design with the software team could provide this one file. This
provides a very compact and portable method to send a Zyng Hardware Platform to a colleague.

4 | MiniZed_Basic_System - MName Date medified Type Size
MiniZed_Basic_System.cache . )
o . | Systern_wrapper.hdf 6/5/2017 1:45 PM HDF File 351 KB
MiniZed_Basic_System.hw

MiniZed_Basic_System.ip_user_files

m

MiniZed_Basic_Systerm.runs
MiniZed_Basic_Systemn.sdk
MiniZed_Basic_System.sim

MiniZed_Basic_Systemn.srcs

Figure 30 — Zynq Hardware Platform Export for SDK

The next tutorial will show you how to open SDK, import a hardware platform, and run Hello
World.
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Revision History

. Date  Verson  Revison
23 Aug 2013 2013_2.01 Initial Avnet release for Vivado 2013.2
02 Jun 2014 2014 _1.01 Update for2014.1 using Avnet MicroZed board definition archive.
11Jun 2014 2014_2.01 Update for 2014.2. Export hardware now produces HDF file.
29Jun 2015 2015_1.01 Update for 2015.1. Added support for MicroZed 7020 and PicoZed

7010/15/20/30.

15Jul 2015 2015_2.01 Update for 2015.2

06 Apr 2016 2015_4.01 Update for 2015.4. Extra connection for eMMC no longer
necessary. Added instruction for new PicoZed board definitions
to connect the AXI GPIO.

01Jun2016 2015 4.02 Update for 2015.4. Added instruction clarification for Run
Automation.

15 Sept 2016 2016_2.01 Updated for 2016.2. Minor figure changes.
20Jan 2017 2016_4.01 Updatedto 2016.4.
05Jun 2017 2017_1.01 Updatedto 2017.1 for MiniZed only
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